re = /S\[[^]]*\](*SKIP)(*FAIL)|\((?:[^()]|(?R))*\)/m
str = 'I am a (test) S[ but i am (not catched)], catch (me (if you (()(())) can))'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end