$re = '/S\[[^]]*\](*SKIP)(*FAIL)|\((?:[^()]|(?R))*\)/m';
$str = 'I am a (test) S[ but i am (not catched)], catch (me (if you (()(())) can))';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);