const regex = /<\/[a-z]+\s*\r?\n/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<\\\/[a-z]+\\s*\\r?\\n', 'gm')
const str = ` <gcusf><gcusfname>SEND-SU-01</gcusfname>
<gcusfvalue>'||"TO CHECK AUTOMATIC DISCART FOR USER"'</gc
usfvalue>
</gcusf>
<gcrvalf>YYMMDD</gcrvalf><gcrvalt>YYMMDD</gcrvalt>
<gcrundesc>'MY DESC YYMMDD -L2,-L4,-L5 OF WEEK'</gcrunde
sc><gcrunrule>E</gcrunrule><gcrtype>N</gcrtype><gcriat>2300</gcriat>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}