re = /<\/[a-z]+\s*\r?\n/m
str = ' <gcusf><gcusfname>SEND-SU-01</gcusfname>
<gcusfvalue>\'||"TO CHECK AUTOMATIC DISCART FOR USER"\'</gc
usfvalue>
</gcusf>
<gcrvalf>YYMMDD</gcrvalf><gcrvalt>YYMMDD</gcrvalt>
<gcrundesc>\'MY DESC YYMMDD -L2,-L4,-L5 OF WEEK\'</gcrunde
sc><gcrunrule>E</gcrunrule><gcrtype>N</gcrtype><gcriat>2300</gcriat>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end