import re
regex = re.compile(r"<\/[a-z]+\s*\r?\n", flags=re.MULTILINE)
test_str = (" <gcusf><gcusfname>SEND-SU-01</gcusfname>\n"
"<gcusfvalue>'||\"TO CHECK AUTOMATIC DISCART FOR USER\"'</gc\n"
"usfvalue>\n"
" </gcusf>\n"
" <gcrvalf>YYMMDD</gcrvalf><gcrvalt>YYMMDD</gcrvalt>\n"
"<gcrundesc>'MY DESC YYMMDD -L2,-L4,-L5 OF WEEK'</gcrunde\n"
"sc><gcrunrule>E</gcrunrule><gcrtype>N</gcrtype><gcriat>2300</gcriat>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")