import Foundation
let pattern = #"<\/[a-z]+\s*\r?\n"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
<gcusf><gcusfname>SEND-SU-01</gcusfname>
<gcusfvalue>'||"TO CHECK AUTOMATIC DISCART FOR USER"'</gc
usfvalue>
</gcusf>
<gcrvalf>YYMMDD</gcrvalf><gcrvalt>YYMMDD</gcrvalt>
<gcrundesc>'MY DESC YYMMDD -L2,-L4,-L5 OF WEEK'</gcrunde
sc><gcrunrule>E</gcrunrule><gcrtype>N</gcrtype><gcriat>2300</gcriat>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)