package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^(\d+-\d+-\d+)_(\d+:\d+:\d+)\.\d+_(\d+)_\d+_(\d+)\.jpg$`)
var str = `2019-12-05_18:02:28.801656_104_1_1575549141338.jpg`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}