import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\d+-\\d+-\\d+)_(\\d+:\\d+:\\d+)\\.\\d+_(\\d+)_\\d+_(\\d+)\\.jpg$";
final String string = "2019-12-05_18:02:28.801656_104_1_1575549141338.jpg";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}