import Foundation
let pattern = #"^(\d+-\d+-\d+)_(\d+:\d+:\d+)\.\d+_(\d+)_\d+_(\d+)\.jpg$"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"2019-12-05_18:02:28.801656_104_1_1575549141338.jpg"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}