re = /^(\d+-\d+-\d+)_(\d+:\d+:\d+)\.\d+_(\d+)_\d+_(\d+)\.jpg$/
str = '2019-12-05_18:02:28.801656_104_1_1575549141338.jpg'
# Print the match result
str.match(re) do |match|
puts match.to_s
end