using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[ .\n]";
string substitution = @"_";
string input = @"DEEP-315
Log exception details to database and display it's unique identifier to the user";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}