$re = '/[ .\n]/m';
$str = 'DEEP-315
Log exception details to database and display it\'s unique identifier to the user';
$subst = "_";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;