use strict;
my $str = 'DEEP-315
Log exception details to database and display it\'s unique identifier to the user';
my $regex = qr/[ .\n]/mp;
my $subst = '_';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";