using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[ \t]([^+]+)[ \t]\+{3}\$\+{3}[ \t]+([^+]+)$";
string input = @"L1045 +++$+++ u0 +++$+++ m0 +++$+++ BIANCA +++$+++ They do not!";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}