re = /[ \t]([^+]+)[ \t]\+{3}\$\+{3}[ \t]+([^+]+)$/m
str = 'L1045 +++$+++ u0 +++$+++ m0 +++$+++ BIANCA +++$+++ They do not!'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end