$re = '/[ \t]([^+]+)[ \t]\+{3}\$\+{3}[ \t]+([^+]+)$/m';
$str = 'L1045 +++$+++ u0 +++$+++ m0 +++$+++ BIANCA +++$+++ They do not!';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);