package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[ \t]([^+]+)[ \t]\+{3}\$\+{3}[ \t]+([^+]+)$`)
var str = `L1045 +++$+++ u0 +++$+++ m0 +++$+++ BIANCA +++$+++ They do not!`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}