use strict;
my $str = 'admin.xyz.mil:Global:Gov:_United States:_xyz:DIG:OV:XE:XE6:;00000643565
operationalaccreditation.xyz.mil:Global:_NET-U MS CON ID 12543:;0000235674
operationalaccredit.xyz.mil:Global:_MON-U NS BON ID 21558:; 0000235674';
my $regex = qr/^(?P<DATT_NAME>.*?):(?P<DATT_KEY>.+?)\s?(?P<DITPR_ID_FULL>ID (?P<DITPR_ID>[0-9]+))?:;[ 0]+(?P<DATT_ID>[0-9]+)$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}