import re
regex = re.compile(r"^(?P<DATT_NAME>.*?):(?P<DATT_KEY>.+?)\s?(?P<DITPR_ID_FULL>ID (?P<DITPR_ID>[0-9]+))?:;[ 0]+(?P<DATT_ID>[0-9]+)$", flags=re.MULTILINE)
test_str = ("admin.xyz.mil:Global:Gov:_United States:_xyz:DIG:OV:XE:XE6:;00000643565\n"
"operationalaccreditation.xyz.mil:Global:_NET-U MS CON ID 12543:;0000235674\n"
"operationalaccredit.xyz.mil:Global:_MON-U NS BON ID 21558:; 0000235674")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")