$re = '/^(?P<DATT_NAME>.*?):(?P<DATT_KEY>.+?)\s?(?P<DITPR_ID_FULL>ID (?P<DITPR_ID>[0-9]+))?:;[ 0]+(?P<DATT_ID>[0-9]+)$/m';
$str = 'admin.xyz.mil:Global:Gov:_United States:_xyz:DIG:OV:XE:XE6:;00000643565
operationalaccreditation.xyz.mil:Global:_NET-U MS CON ID 12543:;0000235674
operationalaccredit.xyz.mil:Global:_MON-U NS BON ID 21558:; 0000235674';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);