// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?P<DATT_NAME>.*?):(?P<DATT_KEY>.+?)\s?(?P<DITPR_ID_FULL>ID (?P<DITPR_ID>[0-9]+))?:;[ 0]+(?P<DATT_ID>[0-9]+)$").unwrap();
let string = "admin.xyz.mil:Global:Gov:_United States:_xyz:DIG:OV:XE:XE6:;00000643565
operationalaccreditation.xyz.mil:Global:_NET-U MS CON ID 12543:;0000235674
operationalaccredit.xyz.mil:Global:_MON-U NS BON ID 21558:; 0000235674";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}