using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!unwanted\n)(expression2)[ ]+(expression3)";
string input = @"unwanted
expression2 expression3 // Not Matched...
string
expression2 expression3 // Matched...";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}