$re = '/(?<!unwanted\n)(expression2)[ ]+(expression3)/';
$str = 'unwanted
expression2 expression3 // Not Matched...
string
expression2 expression3 // Matched...';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);