import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<!unwanted\\n)(expression2)[ ]+(expression3)";
final String string = "unwanted\n"
+ "expression2 expression3 // Not Matched...\n\n"
+ "string\n"
+ "expression2 expression3 // Matched...";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}