const regex = /(?<!unwanted\n)(expression2)[ ]+(expression3)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<!unwanted\\n)(expression2)[ ]+(expression3)', 'g')
const str = `unwanted
expression2 expression3 // Not Matched...
string
expression2 expression3 // Matched...`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}