use strict;
my $str = 'A_File1_Page1
A_File1_Page2
A_File2_Page1
A_File2_Page2
A_File2_Page3
B_File1_Page1
B_File1_Page2
B_File1_Page3
B_File2_Page1
B_File2_Page2
B_File2_Page3
B_File2_Page4
C_File1_Page1
C_File1_Page2
C_File1_Page3
C_File1_Page4
C_File1_Page5';
my $regex = qr/.*Page/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}