import re
regex = re.compile(r".*Page")
test_str = ("A_File1_Page1\n"
"A_File1_Page2\n\n"
"A_File2_Page1\n"
"A_File2_Page2\n"
"A_File2_Page3\n\n"
"B_File1_Page1\n"
"B_File1_Page2\n"
"B_File1_Page3\n\n"
"B_File2_Page1\n"
"B_File2_Page2\n"
"B_File2_Page3\n"
"B_File2_Page4\n\n"
"C_File1_Page1\n"
"C_File1_Page2\n"
"C_File1_Page3\n"
"C_File1_Page4\n"
"C_File1_Page5")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")