re = /.*Page/
str = 'A_File1_Page1
A_File1_Page2
A_File2_Page1
A_File2_Page2
A_File2_Page3
B_File1_Page1
B_File1_Page2
B_File1_Page3
B_File2_Page1
B_File2_Page2
B_File2_Page3
B_File2_Page4
C_File1_Page1
C_File1_Page2
C_File1_Page3
C_File1_Page4
C_File1_Page5'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end