re = /<table\b.*?\bclass\s*=\s*(['"]).*?\btest\b.*?\1.+?<\/table>/
str = '<table><tr><td><span class="test">bla bla bla</span></td></tr></table>'
# Print the match result
str.match(re) do |match|
puts match.to_s
end