using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<(span).*?(/\1)>";
string input = @";decreasing'>1</a> <span class='active'>2</span><a href='F;search&
";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}