const regex = new RegExp('<(span).*?(/\\1)>', '')
const str = `;decreasing'>1</a> <span class='active'>2</span><a href='F;search&
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}