re = /<(span).*?(\/\1)>/
str = ';decreasing\'>1</a> <span class=\'active\'>2</span><a href=\'F;search&
'
# Print the match result
str.match(re) do |match|
puts match.to_s
end