$re = '/assorted-customer-choices\/(?!03c4cbb1-7376-4141-b7c0-aed1fd0b779b$).*$/m';
$str = 'assorted-customer-choices/03c4cbb2-7376-4141-b7c0-aed1fd0b779a
assorted-customer-choices/03c4cbb1-7376-4141-b7c0-aed1fd0b779b';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);