import Foundation
let pattern = #"assorted-customer-choices\/(?!03c4cbb1-7376-4141-b7c0-aed1fd0b779b$).*$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
assorted-customer-choices/03c4cbb2-7376-4141-b7c0-aed1fd0b779a
assorted-customer-choices/03c4cbb1-7376-4141-b7c0-aed1fd0b779b
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)