# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/[\s\S\n]*?(?<=from company).*?(\d+)[\s\S\n]*?/$1\n/gm;t' <<< "Blabla from company blabla $42
Blabla from company blabla $666
Blabla from company blabla $69
"