$re = '/[\s\S\n]*?(?<=from company).*?(\d+)[\s\S\n]*?/m';
$str = 'Blabla from company blabla $42
Blabla from company blabla $666
Blabla from company blabla $69
';
$subst = "$1\n";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;