import Foundation
let pattern = #"[\s\S\n]*?(?<=from company).*?(\d+)[\s\S\n]*?"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Blabla from company blabla $42
Blabla from company blabla $666
Blabla from company blabla $69
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1\n"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)