import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[\\s\\S\\n]*?(?<=from company).*?(\\d+)[\\s\\S\\n]*?";
final String string = "Blabla from company blabla $42\n\n"
+ "Blabla from company blabla $666\n\n"
+ "Blabla from company blabla $69\n";
final String subst = "$1\\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}