import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:(?<=%\\()|(?<=\\{))([^\\)\\{]*)(?=[\\}\\)])";
final String string = "# Example functions using print that we want to extract the substitution args from\n\n"
+ " def Initialise(self):\n"
+ " print '# NDOverlayConfigure(portName, queueSize, blockingCallbacks, NDArrayPort, NDArrayAddr, NOverlays, maxBuffers, maxMemory, priority, stackSize, maxThreads)'\n"
+ " print 'NDOverlayConfigure(\"%(PORT)s\", %(QUEUE)d, %(BLOCK)d, \"%(NDARRAY_PORT)s\", %(NDARRAY_ADDR)s, %(NOverlays)d, 0, 0, 0, 0, %(MAX_THREADS)d)' % self.__dict__\n\n\n\n"
+ " def Initialise(self):\n"
+ " print('# NDROIStatConfigure(portName, queueSize, blockingCallbacks, '\n"
+ " 'NDArrayPort, NDArrayAddr, maxROIs, maxBuffers, maxMemory,'\n"
+ " 'priority', 'stackSize', 'maxThreads')\n"
+ " print('NDROIStatConfigure(\"{PORT}\", {QUEUE}, {BLOCK}, '\n"
+ " '\"{NDARRAY_PORT}\", {NDARRAY_ADDR}, {MAX_ROIS}, '\n"
+ " '0, 0, 0, 0, {MAX_THREADS})'.format(**self.__dict__))\n\n\n\n"
+ " def Initialise(self):\n"
+ " print '# NDStdArraysConfigure(portName, queueSize, blockingCallbacks, NDArrayPort, NDArrayAddr, maxBuffers, maxMemory, priority, stackSize, maxThreads)'\n"
+ " print 'NDStdArraysConfigure(\"%(PORT)s\", %(QUEUE)d, %(BLOCK)d, \"%(NDARRAY_PORT)s\", %(NDARRAY_ADDR)s, 0, 0, 0, 0, %(MAX_THREADS)d)' % self.__dict__\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}