import re
regex = re.compile(r"(?:(?<=%\()|(?<={))([^\){]*)(?=[}\)])", flags=re.MULTILINE)
test_str = ("# Example functions using print that we want to extract the substitution args from\n\n"
" def Initialise(self):\n"
" print '# NDOverlayConfigure(portName, queueSize, blockingCallbacks, NDArrayPort, NDArrayAddr, NOverlays, maxBuffers, maxMemory, priority, stackSize, maxThreads)'\n"
" print 'NDOverlayConfigure(\"%(PORT)s\", %(QUEUE)d, %(BLOCK)d, \"%(NDARRAY_PORT)s\", %(NDARRAY_ADDR)s, %(NOverlays)d, 0, 0, 0, 0, %(MAX_THREADS)d)' % self.__dict__\n\n\n\n"
" def Initialise(self):\n"
" print('# NDROIStatConfigure(portName, queueSize, blockingCallbacks, '\n"
" 'NDArrayPort, NDArrayAddr, maxROIs, maxBuffers, maxMemory,'\n"
" 'priority', 'stackSize', 'maxThreads')\n"
" print('NDROIStatConfigure(\"{PORT}\", {QUEUE}, {BLOCK}, '\n"
" '\"{NDARRAY_PORT}\", {NDARRAY_ADDR}, {MAX_ROIS}, '\n"
" '0, 0, 0, 0, {MAX_THREADS})'.format(**self.__dict__))\n\n\n\n"
" def Initialise(self):\n"
" print '# NDStdArraysConfigure(portName, queueSize, blockingCallbacks, NDArrayPort, NDArrayAddr, maxBuffers, maxMemory, priority, stackSize, maxThreads)'\n"
" print 'NDStdArraysConfigure(\"%(PORT)s\", %(QUEUE)d, %(BLOCK)d, \"%(NDARRAY_PORT)s\", %(NDARRAY_ADDR)s, 0, 0, 0, 0, %(MAX_THREADS)d)' % self.__dict__\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")