using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?i)(https\:\/\/){1}((t\.me|telegram\.me)\/){1}(joinchat\/)?(([\+\_\-a-zA-Z0-9])+)$";
string input = @"join https://t.me/+8Wkkhz_JSIJjN2Rk
join https://t.me/+8Wkkhz_JSIJjN2Rk
join https://t.me/+8Wkkhz_JSIJjN2Rk
join https://telegram.me/+8Wkkhz_JSIJjN2Rk
join https://t.me/joinchat/GsyKEdRaawQ3ZDc8";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}