package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?i)(https\:\/\/){1}((t\.me|telegram\.me)\/){1}(joinchat\/)?(([\+\_\-a-zA-Z0-9])+)$`)
var str = `join https://t.me/+8Wkkhz_JSIJjN2Rk
join https://t.me/+8Wkkhz_JSIJjN2Rk
join https://t.me/+8Wkkhz_JSIJjN2Rk
join https://telegram.me/+8Wkkhz_JSIJjN2Rk
join https://t.me/joinchat/GsyKEdRaawQ3ZDc8`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}