import re
regex = re.compile(r"^(?:Manifest.*|.*\.[sS][iI][gG]|.*\.[tT][aA][rR]|[0-9]{2}-[0-9]{2}.*|first.*|latest.*)$", flags=re.MULTILINE)
test_str = ("Manifest.MoM.tar\n"
"Manifest-random-pack\n"
"Manifest.full\n"
"latest\n"
"latest_version\n"
"latest.sig\n"
"latest_version.sig\n"
"first\n"
"first.sig\n"
"10-20-randomnumber\n"
"randomnumber.tar")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")