import Foundation
let pattern = #"^(?:Manifest.*|.*\.[sS][iI][gG]|.*\.[tT][aA][rR]|[0-9]{2}-[0-9]{2}.*|first.*|latest.*)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Manifest.MoM.tar
Manifest-random-pack
Manifest.full
latest
latest_version
latest.sig
latest_version.sig
first
first.sig
10-20-randomnumber
randomnumber.tar
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)