#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=[A-Z0-9/.-]{5,}\s).*"
Local $sString = "Test ABC123 Test" & @CRLF & _
"ABC123 Test" & @CRLF & _
"Test ABC123" & @CRLF & _
"Test ABC-123 Test" & @CRLF & _
"ABC-123 Test" & @CRLF & _
"Test ABC-123" & @CRLF & _
"Test ABC/123 Test" & @CRLF & _
"ABC/123 Test" & @CRLF & _
"Test ABC/123"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")