const regex = /(?<=[A-Z0-9/.-]{5,}\s).*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=[A-Z0-9\/.-]{5,}\\s).*', 'gm')
const str = `Test ABC123 Test
ABC123 Test
Test ABC123
Test ABC-123 Test
ABC-123 Test
Test ABC-123
Test ABC/123 Test
ABC/123 Test
Test ABC/123`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}