re = /(?<=[A-Z0-9\/.-]{5,}\s).*/m
str = 'Test ABC123 Test
ABC123 Test
Test ABC123
Test ABC-123 Test
ABC-123 Test
Test ABC-123
Test ABC/123 Test
ABC/123 Test
Test ABC/123'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end