$re = '/^(\w+\s\w+(?:\s\w+)?)\s(\d{2}\.\d{2}\.\d{4})\s(\d+)$/um';
$str = 'Иванов Иван Иванович 01.01.1970 353
Иванов Иван 01.01.1970 353';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);