#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^((?:Final)|(?:\d{2}:\d{2})|(?:\d{1,3}(?!\d)(?!-)))"
Local $sString = "PERU" & @CRLF & _
"Liga 2" & @CRLF & _
"]" & @CRLF & _
"Final" & @CRLF & _
"Santa Rosa" & @CRLF & _
"" & @CRLF & _
"0-3" & @CRLF & _
"" & @CRLF & _
"Molinos El Pirata" & @CRLF & _
"" & @CRLF & _
"73 " & @CRLF & _
"Chavelines" & @CRLF & _
"" & @CRLF & _
"1-0" & @CRLF & _
"" & @CRLF & _
"Deportivo Coopsol" & @CRLF & _
"" & @CRLF & _
"20:30" & @CRLF & _
"Comerciantes Unidos" & @CRLF & _
"" & @CRLF & _
"-" & @CRLF & _
"" & @CRLF & _
"Juan Aurich" & @CRLF & _
"22:45" & @CRLF & _
"Santos FC" & @CRLF & _
"" & @CRLF & _
"-" & @CRLF & _
"" & @CRLF & _
"Huaral" & @CRLF & _
"" & @CRLF & _
"90+1 " & @CRLF & _
"Pogon Szczecin" & @CRLF & _
"" & @CRLF & _
"2-0" & @CRLF & _
"" & @CRLF & _
"Stal Mielec" & @CRLF & _
"" & @CRLF & _
"live" & @CRLF & _
"20:30" & @CRLF & _
"Plock" & @CRLF & _
"" & @CRLF & _
"-" & @CRLF & _
"" & @CRLF & _
"Gornik Z." & @CRLF & _
"" & @CRLF & _
"21:15" & @CRLF & _
"Farense" & @CRLF & _
"" & @CRLF & _
"-" & @CRLF & _
"" & @CRLF & _
"Maritimo" & @CRLF & _
""
Local $sSubst = "newLine$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)