# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^((?:Final)|(?:\d{2}:\d{2})|(?:\d{1,3}(?!\d)(?!-)))"
test_str = ("PERU\n"
"Liga 2\n"
"]\n"
"Final\n"
"Santa Rosa\n\n"
"0-3\n\n"
"Molinos El Pirata\n\n"
"73 \n"
"Chavelines\n\n"
"1-0\n\n"
"Deportivo Coopsol\n\n"
"20:30\n"
"Comerciantes Unidos\n\n"
"-\n\n"
"Juan Aurich\n"
"22:45\n"
"Santos FC\n\n"
"-\n\n"
"Huaral\n\n"
"90+1 \n"
"Pogon Szczecin\n\n"
"2-0\n\n"
"Stal Mielec\n\n"
"live\n"
"20:30\n"
"Plock\n\n"
"-\n\n"
"Gornik Z.\n\n"
"21:15\n"
"Farense\n\n"
"-\n\n"
"Maritimo\n")
subst = "newLine$1"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.